Scan-and-Solve for Rhino

Simulate Early, Simulate Often... In Rhino

Where I work, we purchased a floating license of scan and Solve, but it seems that we regularly run into situations where we get a message stating something like "Failed to connect to license server".

Today, I ran into a situation where I couldn't open large Rhino files anymore : it seemed to take ages.

So I un-installed Scan-and solve, and it went back to normal.

Is it possible that SNS tries to locate the license server as I open a Rhino file, and ans it fails doing so, runs into an infinite loop preventing the loading of the file ?

Please help ; we've got lots of analysis to do these days, and can't waste time on silly license management software trouble.



Views: 430

Reply to This

Replies to This Discussion


If a Rhino file contains Scan&Solve data, Rhino calls on the Scan&Solve plug-in to read the data.  The SnS plug-in does do some minor license checking at the time the plug-in loads.  If the server is unreachable, or a license is unavailable (maybe someone else is using it), then there may be a delay as the system waits for a license to become available.  This hasn't come up before, so I'll do some testing and attempt to duplicate the problem.

Is there a reason the license server would be unreachable?  Are you getting any error messages at the server?  Does the entry in %programdata%\Scan&Solve\license.lic match the name of your license server?


I did some checking.  The SnS plug-in does not contact the server during plug-in loading, or during data reading, or during data writing - so the delay is probably not due to the licensing system.

That said, if you are getting license errors you should verify the server information as mentioned above, and check for error messages at the server.

Do you want us to take a look at the Rhino file?


Hi Michael,

I'm not sure what happened with those files, but as soon as I un-installed Scan and Solve, the problem disappeared.

Regarding the floating license, we've been having server trouble lately, and I suspect that after a server reboot, the SNS license service was not re-launched, causing us to lose ability to use the software.

I'll check than on Moday with the IT guys...




License server up and running again.

A script was added on the server so that it is launched systematically at boot time.

Still not sure what happen with the Rhino locking though.

Could be un-related to SNS ; just a coincidence.




© 2024   Created by Michael Freytag.   Powered by

Badges  |  Report an Issue  |  Terms of Service