Scan-and-Solve for Rhino

Simulate Early, Simulate Often... In Rhino


I was working on a file yesterday and everything was going well. Opened that file again this morning to continue and every time I run SnS it stalls and doesn't allow any input. Attached screenshot shows the command line.

NotesModel is preselected.

Can still rotate and pan view

Cannot close Rhino or SnS.

Esc does nothing.

F2 brings up command history.

SnS window doesn't pop up (and isn't hidden behind layer or other panes).

Resort to task manager to close it all down.



Views: 208


Reply to This

Replies to This Discussion

More information...

Copying and pasting the geometry to another instance of rhino doesn't work, same result.

Simple new geometry works (cantilever beam).

So I'm guessing there is something wrong with the saved plugin data. What is saved with the geometry by SnS. Is there a way to purge this data?



No naked or non-manifold edges.

Not a bad object.

Last run of SnS was at max resolution (200000).

Hello Nick,

If you'd like, email the 3dm file to and we'll try to diagnose the problem.  What version of Scan&Solve are you running?

You can purge SnS data by exploding the solid and joining the pieces back together.  SnSScript also contains a command, Reset(), that will remove Scan&Solve data from the solid.  You just need to use the Scan&Solve WIP and write a little RhinoScript.  We can help you with that if you're interested.


G'day Michael,

File is 21MB so too big for email. Do you have a preferred alternative?




You should have an email message inviting you to upload it to a shared Google drive.




© 2024   Created by Michael Freytag.   Powered by

Badges  |  Report an Issue  |  Terms of Service